Speedtest

< All Topics

The RouterOS system allows to generate a Bandwidth tests both in Downlink and Uplink.

This feature works between two RouterOS device : one has to be the server, configured in the section Tools / BTest Server while the other will be the client, configured in the section Tools / Bandwidth Test.

Cloutik integrates a SpeedTest feature which help you to generate a Bandwidh test towards a server hosted in the Cloutik Datacenter based in Europe.

You can also define your own Speedtest configuration targeting another RouterOS server configured as a “BTest Server”.
Assuming that your have configured your target by enabling the BTest Server” (select both “Enabled” and “Authenticate”), here is the Configuration that you can define in your Cloutik account :

:global token “[Cloutik-Token-of-the-device]”;
:global sn [/system routerboard get serial-number];
:global datetime “$[/system clock get date] $[/system clock get time]”;
:global result; :global bwtarget “[The IP Address to join your Target]”;
:local bwuser “[The account login defined in your Target]”;
:local bwpwd “[The account password defined in your Target]”;
:global bwduration “5s”;
:global dutn;:global txc;:global txt10;:global txta;
/tool bandwidth-test duration=$bwduration user=$bwuser password=$bwpwd address=$bwtarget protocol=tcp direction=transmit do={:set result $status; :set dutn $duration; :set txc ($”tx-current” / 1000); :set txt10 ($”tx-10-second-average” / 1000); :set txta ($”tx-total-average” / 1000);
/tool fetch url=”https://login.cloutik.com/bandwidth.php\?sn=$sn&token=$token&op=bandwidth&date=$datetime&status=$result&duration=$dutn&tx-current=$txc&tx-10-current=$txt10&tx-total-average=$txta” mode=https http-method=get dst-path=bandwidth.txt}

Of course, your Target has to be reachable from the other device that will launch the Speedtest operation.
Do not forget to create an account in the section System / Users to authorize your device to achieve the bandwidth testing operation.

You can also select througt the parameter “Direction” if you want to do the bandwidth test in uplink, downlink or both sides.

Note that the values are in Kbps. You can improve it to get Mbps instead.

Be careful : when the device is launching a Bandwidh Test, it uses all its resources to do this test. Then, it could prevent it from achieving other operations. This is why we recommend to limit the Duration to 5 seconds.

The last part of the script triggers an upload of the result, contained in the file “bandwidth.txt” in the Speedtest section of the device on Cloutik. You can also upload this result in your Directory if you prefer.

The Mikrotik forum has a specific section to reference “NEW Public Bandwith Test Server“. You can give a try & see if they provide some interesting results. The availability of such servers is not guarantee and they have also some limitations to prevent from abuses.

The technical reference to manage the Bandwidth Test settings is here : Manual:Tools/Bandwidth Test

Table of Contents